
Makroer � narayana press
til klargøring af tekst i Word

Sidst revideret 30. 3. 2014	 Wordmakroer� Side 1 af 6

Makroer er foruddefinerede søgninger, som kan bruges til 

hurtigt og sikkert at rette almindelige indskrivningsfejl, og 

forebygge at formatering går tabt.

Sådan bruges makroerne

I Word 2003 aktiveres makroerne ved at klikke på de ønskede 

funktioner i de tilhørende Toolbars. Toolbars fungerer ikke i 

nyere versioner af Word; se nærmere side 4.

Makroerne er fordelt på to Toolbars, en til almindelig 

tekstbehandling og -klargøring, og en specielt til noter.

Hvis man kommer til at klikke dem væk, kan de hentes frem 

igen via View > Toolbars.

Nogle makroer skal helst bruges først, andre helst sidst. Den 

anbefalede rækkefølge fremgår af placeringen i Toolbars. 

De fleste makroer virker kun i den aktuelle tekstkæde. Det 

kan være en fordel først at flytte tekst ud af »løse« tekstbokse, 

og eventuelt ændre boksene til tabeller. Bemærk også, at 

enkelte makroer kun er beregnet til at bruges i notetekst. 

Der kan også være tilfælde, hvor en makro ikke bør bruges. 

I det følgende beskrives, hvad hver enkelt makro gør, med 

kursiverede eksempler på, hvad man skal være forsigtig med.

Bemærk at visse søgninger er risikable at ændre i Word, fordi 

man risikrer at ændre formateringen. Flgende er bedre at 

gøre i layoutprogrammet, hvor man også kan vælge ikke at 

søge i specielle teksttyper, som fx hyperlinks:

•	 at indsætte nonbreaking spaces for at ungå linjedelinger i 

forbindelse med §, stk., nr., fig., kl., km, cm, kg, kr., …, –, ff, 

pp, %, s., m, mm og f. Kr. og lignende

•	 at udskifte anførselstegn til de rigtige typer via Søg & Erstat, 

og at fjerne uønskede ordmellemrum i forbindelse med 

anførselstegn (se evt. vejledning om anførselstegn på www.

narayana.dk) 

•	 at erstatte uægte brøker med ægte

Tekstmakroer

Dokumentnormalisering  

Slår Track changes-funktionen fra, og accepterer alle 

ændringer. 

Bruges altid først. 

Tegnudlusning  

Retter følgende almindelige indskrivningsfejl:

•	 Dobbelte ordmellemrum erstattes med enkelte.

•	 Ordmellemrum omkring tabulatorer fjernes.

•	 Ordmellemrum i begyndelsen af afsnit fjernes.

•	 Ordmellemrum fjernes før , . ; : ! ? ) og efter (

•	 3 punktummer erstattes med udeladelsestegn (…)

•	 Diskrete bindestreger fjernes. 

•	 Tankestreger efter tal ændres til bindestreger.

•	 �Bindestreger i begyndelsen af afsnit, samt bindestreger 

med ordmellemrum omkring ændres til tankestreger.

Vær forsigtig med at bruge denne makro i andre sprog end 

dansk. Norsk har fx andre regler for brug af tankestreger og 

bindestreger. 

Fjern ordmellemrum før notetal  

Bruges ikke, hvis notetallene skal stå foran ordene.

Erstat Nonbreaking Hyphens 

Erstatter Nonbreaking Hyphens med almindelige 

bindestreger. Dette forhindrer, at de forsvinder ved import fra 

nyere Word-versioner til InDesign.

Erstat Nonbreaking Spaces 

Erstatter nonbreaking spaces med almindelige 

ordmellemrum.  

Bruges ikke, hvis nonbreaking spaces er brugt bevidst. 

Marker Sideskift, Sektioner og Kolonneskift 

Erstatter med »koder« som *** PAGE BREAK *** + ekstra 

linjeskift. Dette forhindrer, at tilfældige tegn i det foregående 

afsnit forsvinder ved import fra nyere versioner af Word, fordi 

fx sideskift følger direkte efter teksten i manus.

http://www.narayana.dk/
http://www.narayana.dk/


Makroer � narayana press
til klargøring af tekst i Word

Sidst revideret 30. 3. 2014	 Wordmakroer� Side 2 af 6

Marker bløde linjeskift 

Erstatter med en »kode«, som som man senere kan søge og 

erstatte overvåget.

Fjern dobbelte tabulatorer 

Erstatter dobbelte tabulatorer med enkelte. 

Bruges med forsigtighed, hvis opstillinger ikke er lavet som 

rigtige tabeller.

Fjern tabulatorer inden linjeskift 

Erstatter tabulatorer før linjeskift med linjeskift.

Fjern tredobbelte linjeskift 

Erstatter tredobbelte linjeskift med dobbelte. 

Marker blindlinjer 

Erstatter dobbelte linjeskift med enkelte, efterfulgt af »koden«  

*** LUFT OVER ***.  

I layoutprogrammet kan man derefter søge »koden« og 

erstatte den med en brødteksttypografi med indbygget luft 

over. Herved undgås blanke linjer øverst på siderne.

Fjern dobbelte linjeskift 

Erstatter dobbelte linjeskift med enkelte.  

Bruges kun hvis der ikke skal være blindlinjer. 

Indsæt tabulator ved valgte afsnit  

Indsætter tabulatorer i begyndelsen af de markerede afsnit, 

og fjerner de dobbelte tabulatorer som kan opstå herved.  

Sådan kan man sikre sig, at der er indryk ved alle nye 

afsnit. Når teksten er formateret, kan uønskede tabulatorer 

i overskrifter og lignende let fjernes ved at søge tabulator 

+ de typografier, hvor der ikke skal være indryk. Uønskede 

tabulatorer efter overskrifter kan fjernes ved at sætte en 

midlertidig tegnform på alle tabulatorer og alle End of 

Paragraph med overskriftstypografi, og derefter søge 

tabulator+End of Paragraph med denne tegnform, og erstatte 

med End of Paragraph.

Farvemarkering 

Farvelægger de mest almindelige formateringstyper.  

I layoutprogrammet kan farverne derefter erstattes med 

tilsvarende tegnforme, evt. ved hjælp af Narayana’s Queries 

til InDesign (se side 5). Herved kan man »frede« den 

formatering man ønsker at bevare, mens alt andet vil 

forsvinde, når man overfører paragrafforme eller vælger Clear 

All Overrides (se side 6).  

Bruges altid tilsidst.  

Bemærk at usædvanlige kombinationer som bølget 

understregning eller ALL CAPS SUPERSCRIPT MED DOBBELT 

UNDERSTREGNING ikke bliver markeret.  

Pas også på, hvis manus indeholder farver som ikke må 

overskrives, eller som er identiske med dem, som makroerne 

overfører:

Word 2003 Word 2007 og nyere

Italic Pink Word_R255_G0_B255

Bold Turqoise Word_R0_G255_B255

Bold Italic Violet Word_R128_G0_B128

Hyperlinks Blue Blue

Underline Regular Sky Blue Word_R0_G204_B255

Underline Italic Plum Plum

Underline Bold Teal Word_R0_G128_B128

Underline Double Aqua Aqua

Strikethrough Dark Red Word_R128_G0_B0

All Caps PALE BLUE PALE BLUE

Small Caps Lavender Word_R204_G153_B255

Superscript regular Red Word_R255_G0_B0

Superscript italic Orange Word_R255_G102_B0

Subscript regular Green Word_R0_G128_B0

Subscript italic Bright Green Word_R0_G255_B0

Highlighted tekst Yellow R=255 G=255 B=0

Endnote Reference Dark Yellow W2007_R128_G128_B0

Footnote Reference Indigo W2007_R51_G51_B153

Fjern Comments 

Sletter alle kommentarer, som kan bevirke at teksten ikke kan 

importeres i layoutprogrammet.

Notemakroer

Highlight fod- og slutnote referencer  

Markerer de to typer noter med hver sin highlightfarve.

Slutnoter til fodnoter  

Konverterer slutnoter til fodnoter.

Fodnoter til slutnoter 

Konverterer fodnoter til slutnoter.  

Kan også bruges til at se, om nummereringen er i orden, og 

om der er noter uden tekst. Hvis noterne skal være slutnoter, 

er det meget nemmere at rette den slags fejl i Word end i 

InDesign, hvor nummereringen ikke opdateres automatisk. 

Bemærk, at hvis der er brugt både fod- og slutnoter, 
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bliver de blandet og omnummereret, og eventuelle 

sektionsopdelinger af fodnotenummerering forsvinder.

Tab omkring slutnotetal  

Indsætter tabulator før og efter slutnotetal, så det bliver muligt 

at få notetallene til at holde højrekant uanset antallet af cifre.  

Bruges kun i selve noteteksten.

Fjern Superscript fra slutnotetal  

Gør slutnotetal ordinære.  

Bruges kun i selve noteteksten.

Sådan installeres makroer i Word 2003 og 
tidligere versioner (.doc)

Makroerne kan bruges ved at hente teksten ind i 

dokumentet, men de kan også installeres permanent:

Slet først eventuelle ældre versioner af Narayana’s makroer 

og Toolbars ved at åbne Word og vælge Tools > Templates 

and Add-Ins… > Organizer… 

Klik på fanebladet Macro Project Items, marker de makroer 

der skal slettes i Normal.dot (global template), og klik Delete.  

Klik på fanebladet Toolbars, marker de Toolbars der skal 

slettes i Normal.dot (global template), og klik Delete.

Luk Word.

Dobbeltklik på dokumentet med makroerne, og vælg Enable 

Macros når du bliver spurgt. 

Hvis makroerne ikke er til rådighed, så prøv at sætte Tools > 

Macro > Security ... til Medium, og luk Word helt ned, inden 

du prøver igen.

Vælg Tools > Templates and Add-Ins… > Organizer…,  

og klik på fanebladet Macro Project Items. Marker alle 

makroerne i dokumentet, og klik Copy. 

Skift til fanebladet Toolbars. Marker de to Toolbars i 

dokumentet, og klik Copy: 

Klik Close, og luk Word. 

Åbn Word igen, og check at makroerne er til rådighed, inden 

dokumentet slettes.

De nye Toolbars med makroer er nu permanent tilgængelige 

på computeren.
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Sådan installeres og bruges makroer i Word 2007 og senere versioner (.docx)

I nyere Word-versioner kan makroerne installeres permanent ved at åbne dokumentet med makroerne, vælge Developer > 

Macros*, og klikke Organizer. 

I det næste vindue klikker man på fanebladet Macro Project Items, markerer alle makroerne i dokumentet, og klikker Copy. 

Toolbars kan ikke overføres, men via Word Options > Quick Access Toolbar kan man selv lægge makroerne ind i Quick 

Access Toolbar, fx som her: 

Det sikreste er at arrangere de makroer, man vil bruge, i samme rækkefølge som er vist herunder, og at vælge nogle ikoner, 

der kan hjælpe en til at huske funktionen. Selve teksten vises nemlig kun i Quick Access Toolbar, når man holder cursor’en 

over ikonet.
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Hvad er en Query?

En Query er en lille xml-fil, som indeholder en forud 

defineret søgefunktion. Hvis du har farvelagt de forskellige 

formateringer i Word med Narayana’s makroer, kan du bruge 

Query’erne til at erstatte farverne med tegnforme og dermed 

forebygge, at formatering går tabt. 

»Pakken« indeholder to sæt Query’er: Et til Word 2003, og et 

til Word 2007 og nyere versioner. Desuden findes en IDML-fil 

med tegnforme, hvis navne svarer til søgningerne. IDML’en 

skal åbnes med InDesign og gemmes i den version, du 

bruger, inden du kan importere tegnformene fra den.

Query’erne fungerer i alle nyere versioner af InDesign, og på 

både Mac og PC.

Sådan installeres Queries

Query’erne skal bare placeres i en mappe for straks at 

være tilgængelige for InDesign. Der er flere muligheder, 

men følgende placeringer er nemme at finde, og gør 

søgefunktionerne tilgængelige for alle brugere:

På Mac lægges de i Applications > Adobe InDesign [version] 

> Presets > Find-Change Queries >Text.

På PC lægges de i Program Files > Adobe > Adobe InDesign 

[version] > Presets > Find-Change Queries > Text.

Tips til import af tekst fra Word

Check at [None] er valgt som Character Style, inden du 

importerer den klargjorte Word-tekst. Ellers risikerer du 

nemlig, at den markerede tegnform »smitter af« på store dele 

af teksten.

Vælg altid Show Import Options for at sikre, at alt kommer 

med, og at Style Conflicts står til Auto Rename (ellers kan 

formatering fra Word ændres under import).

Sådan bruges Queries til formatering

Det er en god ide først at slette unødvendige farver og 

tegnforme fra InDesign dokumentet, fx ved at vælge Select 

All Unused. 

Derefter importeres Narayana’s tegnforme fra dokumentet 

CharacterStyles ved at vælge Load Character Styles ... fra 

drop-down listen i Character-panelet: 

Hvis der forekommer specielle skrifttyper som Dingbats eller 

græske, fonetiske og matematiske tegn (de kan ses i Find 

Font), er det vigtigt først at oprette og overføre tegnforme til 

dem – ellers risikerer man nemlig, at fontinformationen går 

tabt. Det gøres ved at søge Basic Character Formats > Font 

Family + den pågældende skrifttype, og erstatte med en 

tilsvarende tegnform. 
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Det anbefales at sætte tegnformens farve til Black – ellers 

risikerer man, at den bliver overskrevet ved en følgende 

søgning. 

Queries aktiveres ved at vælge Edit > Find/Change, vælge 

den ønskede søgning fra listen, fx W2003_Pink til Italic, 

vælge Search: Document, og klikke Change All. 

Man behøver kun bruge de Queries som svarer til de RGB-

farver, der er kommet ind fra Word. Sådan ser Swatches-

panelet ud, hvis manus indeholder alle de formateringer, der 

bliver markeret:

Hvis enten farven eller tegnformen ikke findes i dokumentet, 

vil der komme en meddelelse som denne:

Hvis man svarer ja til at fortsætte søgningen, vil man se, hvad 

der er galt: Hvis Find Format-feltet er tomt, er det fordi farven 

ikke findes. Hvis Change Format-feltet er tomt, er det fordi 

tegnformen ikke findes.

Når man har søgt og erstattet alle Word-farverne i Swatches-

panelet, vil al farvelagt tekst være blevet erstattet med 

tilsvarende tegnforme. Man kan checke, om man har glemt en 

søgning, ved at vælge Select All Unused.

Hvis manus indeholder specielle formateringer, som ikke 

bliver »fanget« af Word-makroen, fx bølget understregning, 

eller usædvanlige kombinationer som Superscript Small Caps 

med dobbelt understregning, kan man lægge tegnforme på 

disse ved manuelle søgninger, ligesom med specialtegn.

Sådan overføres paragrafforme

Hvis man ønsker at formatere alt som brødtekst, markerer 

man al teksten, og holder alt-tasten nede, mens man klikker 

på brødtekst-formen. Herved bevares kursiver og alt andet, 

som man har »fredet« ved at sætte tegnforme på, mens 

al uønsket formatering forsvinder. Teksten er nu klar til den 

sidste finpudsning, og nye paragrafforme kan overføres uden 

problemer.

Hvis manus har været konsekvent typograferet med 

overskriftsniveauer mm, kan man i stedet erstatte disse med 

sine egne typografier, en ad gangen. Når alle typografier er 

udskiftet, markerer man al teksten, og vælger Clear Overrides 

fra Paragraph Style panelet.

Tekst i tabeller og fodnoter ligger uden for den almindelige 

tekstkæde, og bliver ikke markeret når man vælger alt. 

Her fjernes overrides i stedet ved at søge de pågældende 

paragraf-typografier og erstatte dem med sig selv. Pas på at 

der ikke er tekst i søgefelterne, når du gør dette.

Queries � narayana press
til formatering af tekst i InDesign
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